Error: "vSphere HA agent cannot be correctly installed or configured"
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Error: "vSphere HA agent cannot be correctly installed or configured"

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Article ID: 318929

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Updated On:

Products

VMware vSphere ESXi VMware vSphere ESX 8.x

Issue/Introduction

  • Unable to install or update the vCenter Server vSphere High Availability (vSphere HA) agent service.
  • The vmware-fdm VIB is the package that runs this service on each ESXi host
  • Powering on virtual machines fails with an error that states:

The host is reporting errors in its attempts to provide vSphere HA support

  • In the vCenter Server summary tab, the following vSphere HA service error may be observed:

vSphere HA agent for this host has an error: vSphere HA agent cannot be correctly installed or configure

  • The host disconnects intermittently from vCenter

Environment

  • VMware vSphere ESXi 7.0.x
  • VMware vSphere ESXi 8.0.x
  • VMware vSphere ESX 9.x
  • VMware vCenter Server 7.0.x
  • VMware vCenter Server 8.0.x
  • VMware vCenter Server 9.x

Cause

This issue is typically attributed to one of the following underlying causes:

  • Third-Party VIB Conflicts: Compatibility issues arising from third-party VIBs installed on the ESXi host.

  • Datastore Connectivity: Problems accessing the ESXi host's heartbeat datastore.

  • Operating System Instability: Errors within the underlying OS of either the ESXi host or the vCenter Server.

  • vCLS Malfunctions: Issues specific to the vSphere Clustering Service (vCLS).

  • Version Mismatch: New ESXi hosts deployed into a new cluster that is running a higher build than vCenter.

Resolution

Before proceeding, ensure your ESXi host version is compatible with your vCenter Server version by reviewing the VMware Product Interoperability Matrix. Once this has been confirmed, please follow the steps below in order to resolve the issue.
  1. Verify if the issue described in vSphere HA reports that an agent is in the Agent Unreachable state is present and if confirmed, take the steps as advised in this article.
  2. Confirm if the ESXi host is part of a vSAN cluster, please ensure that:
    1. Its networking is configured for, and participating in the vSAN cluster.
    2. It is showing good health for vSAN per Monitoring and Troubleshooting vSAN.
  3. Next, disconnect, then reconnect the ESXi host with the vCenter Server:
    1. In the vCenter GUI, use the Hosts and Clusters view, 
    2. Right-click the ESXi host and select Connection > Disconnect
    3. Right-click the ESXi host and select Connection > Connect
    4. Disable, then re-enable vSphere HA.
  4. If the problem persists, check whether the vSphere HA agent service needs to be restarted as outlined in Operation timed out" while reconfiguring HA (FDM) on a cluster
  5. If the problem persists, restart the vSphere HA service on the cluster by using the steps described in Disabling and enabling VMware vSphere High Availability (vSphere HA)
  6. If the problem persists, try putting the cluster in retreat mode and taking it out again per Disable vCLS on a Cluster via Retreat Mode.
  7. If the problem persists, follow ESXi host not responding due to high disk space usage in the /tmp directory to verify if the ramdisk partition /tmp is full and resolve this.
  8. If the problem persists, review the /var/run/log/fdm-installer.log file:
    # cat /var/run/log/fdm-installer.log | less
    1. If errors for third-party VIBs such as the one below are observed, see Resolve third-party VIB preventing vSphere HA agent updates:
      bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule: Installing the VIB
      fdm-installer: [24683] 2013-07-18 18:41:45:
      Result of esxcli software vib install -v=/tmp/vmware-root/ha-agentmgr/vpx-upgrade-installer/vmware-fdm.vib [DependencyError]
      fdm-installer:
      VIB QLogic_bootbank_qlogic_hcli_2.2.60.7.0.0vmw.500.0.0.472560 violates extensibility rule checks: [u'(line 31: col 0) Element vib failed to validate content']
    2. If an error in the fdm-installer.log indicates that a reboot is needed, then the host will need to be rebooted
  9. If the problem persists, check for heartbeat datastore problems per Troubleshoot ESXi heartbeat datastore problems affect vSphere HA.
  10. If the problem persists, rule out network issues
    1. Ensure that the MTU size configured for any of the ESXi hosts uplinks (vmnics) is consistent across all switch ports and other infrastructure that allow MTU configuration.
    2. Ensure that no firewall changes were made to the ESXi host or network switches that could be blocking ports 80, 443, 8182 and 902 between hosts and vCenter Server.
  11. If the problem persists, restart the management agents on the ESXi host per Restarting Management agents in ESXi.
  12. If the problem persists, follow the bottom half of the article Resolve third-party VIB preventing vSphere HA agent updates, starting at "To remove the vSphere HA agent VIB".
  13. Upgrade vCenter to the same or higher version of your ESXi host, or downgrade the ESXi host to the same or lower build of your vCenter build.

Additional Information