VMware Cloud Foundation SDDC manager tasks "Fetching subtask info..." shows as running, but the task is stuck at 0%
search cancel

VMware Cloud Foundation SDDC manager tasks "Fetching subtask info..." shows as running, but the task is stuck at 0%

book

Article ID: 318890

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • After a VCF upgrade, in some situations the task panel may display "Fetching subtask info..." and the progress indication is stuck at 0%.
  • This article will help cleanup these tasks from the task panel and avoids any confusion that it may be causing.

OR

Environment

VCF 5.x

VCF 9.x

Cause

This can happen in a scenario where the bundle associated with the upgrades are cleaned up. The bundle_cleanup script has the logic to delete the task registration data, but it seems like the tasks were not successfully cleaned up.

Resolution

Below steps can be followed to remove stale tasks:

1. An SSH session to the SDDC Manager appliance is initiated using the vcf user credentials.

2. Administrative privileges are elevated by executing the command:

  • su -

3. The unique task identifier (<taskid>) is retrieved by hovering over the stuck entry in the SDDC Manager task panel or by copying the identifier directly from the browser URL address bar.

4. The stale registration record is removed by executing the following API invocation from the command line:

  • curl -s -X DELETE localhost/tasks/registrations/<taskid>

5. If the task identifier is unavailable or cannot be determined from the interface, the management platform operations services are restarted:

  • /opt/vmware/vcf/operationsmanager/scripts/cli/sddcmanager_restart_services.sh

Additional Information

Note: This kb can also be run to delete any stale task present in the SDDC UI.