VMware Cloud Foundation NSX-T upgrade pre-check timeout
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VMware Cloud Foundation NSX-T upgrade pre-check timeout

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Article ID: 318755

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:

  • NSX-T upgrade fail  because of timeout
  • lcm-debug.log will have a message as follows:
Note: lcm-debug.log is located in /var/log/vmware/vcf/lcm/lcm-debug.log

 

2021-08-10T08:29:12.425+0000 ERROR [vcf_lcm,06de7cd39b78427c,a309,upgradeId=########-####-####-####-##########,resourceType=NSX_T_PARALLEL_CLUSTER,resourceId=vip-nsxt-wld-01.w2g-qes-001.rainpole.local:_ParallelClusterUpgradeElement,bundleElementId=########-####-####-####-##########] [c.v.e.s.l.p.i.n.s.NsxtEdgeClusterParallelUpgradeStageRunner,ThreadPoolTaskExecutor-6] Marking upgrade elements batch as NSXT_UPGRADE_PRECHECK_TIMEDOUT


 



Environment

VMware Cloud Foundation 4.2
VMware Cloud Foundation 4.3
VMware Cloud Foundation 3.11

Cause

The timeout from LCM happens due to NSXT taking more time to complete the precheck.

Resolution

This issue is resolved in VMware Cloud Foundation 4.5.

Workaround:
To workaround this issue, please follow the below steps:
  1. Update the properties below in LCM properties to increase the timeout values.
Note: File name is application-prod.properties and is located in /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties

lcm.nsxt.edge.precheck.timeout=3600000
lcm.nsxt.host.precheck.timeout=3600000
  1. Restart LCM service
  2. Retry upgrade from SDDC Manager UI