VMware Aria Suite Lifecycle Upgrade Planner Error when using a proxy
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VMware Aria Suite Lifecycle Upgrade Planner Error when using a proxy

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Article ID: 318725

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Upgrade Planner in VMware Aria Suite Lifecycle (formerly vRealize Lifecycle Manager) 8.x user interface shows the following error
! Failed to fetch product versions
  • In the /var/log/vrlcm/vmware_vrlcm.log file you can see logs entries similar to:
    ERROR [http-nio-8080-exec-6] c.v.v.l.u.s.UpgradePlannerServiceImpl - -- Error occured while logging into vvs server. Will try to read it from sim service offline data java.net.SocketTimeoutException: connect timed out
    
    ERROR [http-nio-8080-exec-6] c.v.v.l.u.s.UpgradePlannerServiceImpl - -- Failed to fetch auth token. Skipping compatibility matrix fetch operation from server.


Environment

VMware Aria Suite Lifecycle 8.x
VMware vRealize Suite Lifecycle Manager 8.x

Cause

The issue occurs as there is currently no option to exclude the Upgrade Planner traffic from the configured proxy.

Resolution

This issue is resolved in VMware Aria Suite Lifecycle 8.14.0.


Workaround:
To workaround this issue you may temporarily remove the proxy settings from the appliance.

Procedure

See the Configure your proxy settings section of the VMware Aria Suite Lifecycle 8.x product documentation.

Additional Information

Impact/Risks:

The Upgrade Planner will not display any result when configured behind a proxy.