Cannot download bundles after upgrading SDDC manager to 4.5.x: Download option grayed out
search cancel

Cannot download bundles after upgrading SDDC manager to 4.5.x: Download option grayed out

book

Article ID: 318614

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Reconfigure proxy and connect to VMware Depot to download bundles

Symptoms:

  • LCM Bundle Management section displays "Depot Status not initialized yet"

  • All the services are healthy when checked using /opt/vmware/sddc-support/sos --services-health
  • Future upgrade bundles DOWNLOAD NOW option will be grayed out
  • When clicked on download bundle, bundle gets stuck at Schedule Now option
  • Proxy Settings are missing in the UI after upgrading to VCF 4.5.x
  • Check /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties proxy details will be present
lcm.depot.adapter.proxyEnabled=true
lcm.depot.adapter.proxyHost=proxy IP address
lcm.depot.adapter.proxyPort=proxy port
  • The lcm-app file will have proxy details but Proxy Settings on SDDC Manager UI will be empty



Environment

Vmware Cloud Foundation 4.5.1
Vmware Cloud Foundation 4.5

Cause

  • Proxy Settings from previous SDDC manager version are not persisted in LCM configuration after upgrade to 4.5.x
  • Proxy Settings in 4.5.x are moved to database and not in /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties

Note: Going forward from 4.5.x changing proxy settings in /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties and restarting LCM will not fix the issue. This is due to change in VCF 4.5. All previous versions of VCF will have the proxy settings in /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties.

Resolution

This issue is resolved in VMware Cloud Foundation 5.1.
This issue is resolved in VMware Cloud Foundation 4.5.2.

Workaround:

  • Get the proxy server details from application-prod.properties file using the below command
less /opt/vmware/vcf/lcm/lcm-app/conf/application-prod.properties | grep proxy
  • Configure proxy on the UI by navigating to SDDC UI -> Administration -> Proxy Settings -> Edit -> Configure Proxy
  • Disconnect and reconnect the depot from SDDC UI -> Administration -> Online depot -> Edit -> Authenticate



Additional Information

The greenfield environments upgraded from 4.5 to 4.5.1 would not see this issue, Issue will be observed incase of brownfield environments upgrading from 4.2/4.3/4.5 to 4.5 or 4.5..1

You may encounter the error message “Depot Status not initialized yet”, and the Download options under Bundle Management may appear greyed out.
 
This typically occurs when the firewall is blocking port 443 traffic between the SDDC Manager and dl.broadcom.com
  • To verify connectivity, run the following command from the SDDC Manager:
         nc -zv dl.broadcom.com 443 
  • If the port is open, the command will succeed.

  • If it is blocked, please work with your firewall team to ensure that traffic over the required port 443 is allowed between the SDDC Manager and the depot.