Aria Suite Lifecycle offline product patch mapping issue
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Aria Suite Lifecycle offline product patch mapping issue

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Article ID: 318505

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
 
Offline product patch upload to Aria Suite Lifecycle stop showing progress and fails without giving any error or the request for offline Patch Mapping is not created in Aria Suite Lifecycle Request tab.

Environment

Aria Suite Lifecycle 8.x

Cause

The slow network between the client and LCM causes the patch upload to fail.

Resolution

Please follow the steps to copy the product patch to Aria Suite Lifecycle VA and trigger patch mapping to Aria Suite Lifecycle.
 
1. Download product patch from Customer Connect Patch Portal
 
2. Copy the product patch file to /data folder in Aria Suite Lifecycle VA using SCP.
 
Note: Please make sure /data partition has enough disk space to copy and map the patch, if the storage is not enough, please extend the /data partition storage using EXTEND STORAGE option under Home -> Settings -> System Details tab in Aria Suite Lifecycle UI.
 
3. Add CD to or / data folder and run Curl Command to map Patch to Aria Suite Lifecycle as follows:
 
curl -X POST "http://localhost:8080/lcm/lcops/api/settings/patch/import" -H "accept: */*" -H "Content-Type: multipart/form-data" -H "Authorization: Basic <BASE64 encoded username: password>" -F "file=@{PATCH_FILE}" -k -v
 
Note: In the above curl command, update <BASE64 encoded username: password> to the password in the format username: password encoded using BASE64, and update {PATCH_FILE} to actual patch file name copied to data folder.
 
4. Once the curl command is successful, track the offline Patch Mapping request triggered from above API under Home -> Requests tab in Aria Suite Lifecycle UI.
 
5. Once the offline Patch Mapping request is completed, Patch will be mapped and listed under Home -> Settings -> Binary Mapping ->  Patch Binaries.