Unable to download or map binaries for products in Aria Suite Lifecycle - LCMSOURCEMAPPING10018
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Unable to download or map binaries for products in Aria Suite Lifecycle - LCMSOURCEMAPPING10018

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Article ID: 318499

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Updated On: 04-25-2025

Products

VMware Aria Suite

Issue/Introduction

  • Not able to upload binaries in LCM:

Error Code: LCMSOURCEMAPPING10018
Selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle
One or more selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle: [/data/Prelude_VA-8.18.1.36791-24282366-updaterepo.iso]

  • Manually downloading and mapping the binaries fails with:

Error Code: LCMSOURCEMAPPING10018. Selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle.One or more selected files checksums does not match with any product versions supported by VMware Aria Suite Lifecycle: [/PathToBinary/VMware-vRealize-Log-Insight-8.12.0-21696970.pak]

Environment

  • VMware Aria Suite Lifecycle 8.x
  • Aria Operations for Logs 8.x

Cause

  • The issue occurs when you try to download or map binaries for a product not supported by your LCM version and PSPack.
  • Aria Suite Lifecycle does not accept patches/hotfixes that are not wrapped in the .patch file from the Broadcom Support Portal.
  • Aria Operations/Aria Operations for Logs 8.14 and below versions' hotfixes were not wrapped in .patch files, so the hotfix .pak file for those versions downloaded under the products will not work in LCM.
  • Aria Automation 8.18.1 is not supported by LCM 8.18.0 without PSPAK 3 or above applied.

Resolution

  • Make sure the necessary Product Support Pack version of LCM is applied.

For more information on the product support pack, including installation instructions,s see the Product support pack's release notes:

VMware Aria Suite Lifecycle 8.18 Product Support Pack Release Notes

  • If there are issues with applying Aria Suite products' patches/hotfixes, either apply the applicable newer versions' upgrade PAK file, or the .patch file that contains the patches/hotfixes. Please refer to the following documentation for more details:

Install a patch for products by using VMware Aria Suite Lifecycle

Download VMware Aria Suite Lifecycle product patches

Additional Information

  • If after ensuring the proper Product Support Pack is installed and you're still getting the same error, refer to KB https://knowledge.broadcom.com/external/article/314839 to clear out a potential failed update attempt that left a stale entry in the update_status.json file.