Proceed button is greyed out when attempting to upgrade a managed product in Aria Suite Lifecycle Manager
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Proceed button is greyed out when attempting to upgrade a managed product in Aria Suite Lifecycle Manager

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Article ID: 318497

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Once the inventory sync is complete, when trying to upgrade a managed product from vRSLCM, the PROCEED button cannot be selected.

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  • Opening developer tools in your client browser with F12 and under the Network tab Gateway Time-out errors are found for POST requests to .../lcm/lcops/api/environments
  • The log /var/log/nginx/error.log will contain errors similar to the below
    [error] 839#0: *169 connect() failed (111: Connection refused) while connecting to upstream, client: VC_IP, server: VC_FQDN, request: "GET /lcm/lcops/api/v2/datacenters HTTP/1.1", upstream: "http://127.0.0.1:8080/lcm/lcops/api/v2/datacenters", host: "FQDN of VC", referrer: "https://VC FQDN/lcm/lcops/environments"
  • The vmware_vrlcm.log contains messages similar to
    2022-08-06 04:27:12.709 INFO [http-nio-8080-exec-6] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: vrli-worker
    2022-08-06 04:09:21.107 INFO [http-nio-8080-exec-5] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: remotecollector
    2022-08-06 04:09:12.628 INFO [http-nio-8080-exec-5] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: remotecollector


Environment

VMware vRealize Suite Lifecycle Manager 8.x

Cause

  • When managing a large number of environments, vRSLCM checks if vCenter details is present.
    • If they are missing, it will populate them with the correct values.
  • The default API time out is 60 seconds for this API call.

Resolution

This issue is resolved in vRealize Suite LifeCycle Manager versions 8.10.0


Workaround:

Prerequisites

  • Please take simultaneous non-memory snapshots of the virtual appliance(s).
  • You have access to root user and password
  • You have SSH or console access to each virtual appliance.
Procedure
  1. SSH / PuTTy into the vRSLCM virtual appliance.
  2. Run the following command
    vim /etc/nginx/nginx.conf
  3. Add the following code block ahead of the block that starts with location /lcm/lcops/api/
     location /lcm/lcops/api/environments {
      limit_req zone=mylimit burst=20 nodelay;
      proxy_pass http://vrlcm-server;
      proxy_read_timeout 10m;
      proxy_send_timeout 10m;
     }
  4. Verify nginx conf with the command
    nginx -t
  5. Reload the nginx service with the command
    systemctl reload nginx
  6. Wait between 5-10 minutes then retry the upgrade.
Note: Increment the proxy_read_timeout and proxy_send_timeout values higher based upon the environment size and if the Time-out errors continue.