Once the inventory sync is complete, when trying to upgrade a managed product from vRSLCM, the PROCEED button cannot be selected.
Opening developer tools in your client browser with F12 and under the Network tab Gateway Time-out errors are found for POST requests to .../lcm/lcops/api/environments
The log /var/log/nginx/error.log will contain errors similar to the below
[error] 839#0: *169 connect() failed (111: Connection refused) while connecting to upstream, client: VC_IP, server: VC_FQDN, request: "GET /lcm/lcops/api/v2/datacenters HTTP/1.1", upstream: "http://127.0.0.1:8080/lcm/lcops/api/v2/datacenters", host: "FQDN of VC", referrer: "https://VC FQDN/lcm/lcops/environments"
The vmware_vrlcm.log contains messages similar to
2022-08-06 04:27:12.709 INFO [http-nio-8080-exec-6] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: vrli-worker
2022-08-06 04:09:21.107 INFO [http-nio-8080-exec-5] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: remotecollector
2022-08-06 04:09:12.628 INFO [http-nio-8080-exec-5] c.v.v.l.l.u.EnvironmentTemplateUtil - -- Node type: remotecollector
Environment
VMware vRealize Suite Lifecycle Manager 8.x
Cause
When managing a large number of environments, vRSLCM checks if vCenter details is present.
If they are missing, it will populate them with the correct values.
The default API time out is 60 seconds for this API call.
Resolution
This issue is resolved in vRealize Suite LifeCycle Manager versions 8.10.0
Workaround:
Prerequisites
Please take simultaneous non-memory snapshots of the virtual appliance(s).
You have access to root user and password
You have SSH or console access to each virtual appliance.
Procedure
SSH / PuTTy into the vRSLCM virtual appliance.
Run the following command
vim /etc/nginx/nginx.conf
Add the following code block ahead of the block that starts with location /lcm/lcops/api/