<179>1 2020-02-18T16:29:49.873725+00:00 edgetn01 NSX 29783 SYSTEM [nsx@6876 comp="nsx-edge" subcomp="upgrade-bundle" level="ERROR"] Error sending request to 'http://127.0.0.1:7441/api/v1/node/maintenance-mode': <HTTPError 500: 'Internal Server Error'>2020-02-18T16:29:49.872Z api_access.80 INFO 127.0.0.1 - - [2020-04-11 12:26:49] 'PUT /api/v1/node/maintenance-mode --- New value: {"maintenance_mode": true}' 500 161 "" "Python-urllib/3.5" 4722.339133Depending on the situation, '{"maintenance_mode": true}' could also be '{"maintenance_mode": false}'
14548 1779 33 www-data 00:00:00 0.0 0.0 3564 25040 /usr/bin/nsx-appctl -t /var/run/vmware/nsx-opsagent/opsagent-cli edgesvc/cli/change mmodeThe process to enter/exit maintenance mode on the Edge is stuck in an invalid state.
This issue is resolved in VMware NSX 3.0 and later, available at Broadcom downloads.
If you are having difficulty finding and downloading software, review the Download Broadcom products and software KB.
Workaround:
To workaround this issue, restart the impacted Edge TN.