Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.
The impacted ports are marked as blocked.
#net-dvs -l | grep -E "port |port.block|volatile.status" port ########-####-####-####-##########71: com.vmware.common.port.block = true , propType = POLICY com.vmware.common.port.volatile.status = inUse linkUp blocked portID=67108871 Port blocked by admin propType = RUNTIME
Environment
VMware NSX-T Data Center VMware NSX
Cause
NSX-T periodically performs resync operation so that stale logical ports are cleaned up. However due to a known issue the resync script does not correctly identify VMs that are connected to NSX port groups and VMs are wrongly detached from logical ports.
NOTE: NVDS is not affected by the issue.
Resolution
This is know issue affecting NSX-T 3.0.3 / 3.0.3.1 and is resolved in NSX-T 3.1.2.x / 3.2.x and higher.
Workaround: 1. Connect the affected VM's NIC to another port group and then connect back to the original port groups. 2. Use NVDS in place of VDS to avoid this issue.
Additional Information
Impact/Risks: VMs lose network connectivity if they are connected to NSX-T port groups on vDS.