NSX-T NSX Application Platform UI alarms indicating Critical: Platform Disk Usage Very High
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NSX-T NSX Application Platform UI alarms indicating Critical: Platform Disk Usage Very High

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Article ID: 318274

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You are running NSX Application Platform (NAPP) 3.2.1 or 4.0.1.
  • The NSX-T UI displays alarms indicating:
    • Feature: NSX Application Platform Health
    • Event Type: Platform Disk Usage Very High
    • Severity: Critical
  • With text:
The disk usage of Platform Services service is above the very high threshold value of 90%.
  • Alert seen in NSX-T UI:
  • On the Kubernetes platform where NAPP is deployed, when we check the cluster-api pod for space:
napp-k -n nsxi-platform exec -it `napp-k get pods -n nsxi-platform | grep cluster | cut -d ' ' -f 1` -c cluster-api bash
df -h
We see the directory storing the support bundle is very high or 100%
Filesystem      Size  Used Avail Use% Mounted on
overlay        1008G   27G  940G   3% /
tmpfs            64M     0   64M   0% /dev
tmpfs            32G     0   32G   0% /sys/fs/cgroup
/dev/sda3      1008G   27G  940G   3% /tmp
tmpfs            32G   28K   32G   1% /certs
tmpfs            32G  4.0K   32G   1% /config
tmpfs            32G  8.0K   32G   1% /pkcs-certs
shm              64M     0   64M   0% /dev/shm
/dev/sdb         20G   16G  3.1G  84% /var/log/napp/supportbundle --->>> high usage
tmpfs            32G   12K   32G   1% /run/secrets/kubernetes.io/serviceaccount
tmpfs            32G     0   32G   0% /proc/acpi
tmpfs            32G     0   32G   0% /proc/scsi
tmpfs            32G     0   32G   0% /sys/firmware
 
 



Environment

VMware NSX-T Data Center 3.x
VMware NSX-T Data Center

Cause

The logrotate feature is not quick enough to rotate the logs and thus the files grow to quickly, causing space issues.

Resolution

This issue is resolved in NSX Application Platform 3.2.1.1 available at Broadcom Downloads.

If you believe you have encountered this issue and are unable to upgrade, please open a support request and refer to this KB.

Attachments

cluster_api_patch get_app