SDDC Manager root partition is getting full
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SDDC Manager root partition is getting full

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Article ID: 318240

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Updated On: 01-21-2025

Products

VMware Cloud Foundation

Issue/Introduction

NOTE: In VMware Cloud Foundation 5.x, the nature of this issue is resolved differently. For resolving this issue in VCF 5.x, please refer to https://knowledge.broadcom.com/external/article?articleNumber=327184.
 
 
Symptoms:
  • Root partition getting full  leading to SDDC GUI to be inaccessible.
  • It also results to failed upgrade prechecks.


Environment

VMware Cloud Foundation 4.x

 

Cause

It occurs due to log rotation policy for auth.log and audit.log.

Resolution

This issue is resolved in VMware Cloud Foundation version 4.4.
 
In VMware Cloud Foundation 5.x, the locations for these files have changed. Please use this article instead https://knowledge.broadcom.com/external/article?articleNumber=327184.

Workaround:
To workaround this issue create a log rotation policy manually by doing the following: 

1. Take a  snapshot of SDDC VM.
2.Go to /etc/logrotate.conf and edit the file to have these new added lines:
/var/log/auth.log {
        rotate 5
        daily
        copytruncate
        compress
 }
 
/var/log/audit/audit.log {
         rotate 5 
        daily 
        copytruncate 
        compress
 }

3. Run following command 
 logrotate -f /etc/logrotate.conf
4. Write nothing to the log files audit.log and auth.log : echo > /var/log/auth.log & echo > /var/log/audit/audit.log

 5.Reboot SDDC manager virtual machine.