/var/log/vmware/sso/localhost.*.log grows to large size and filled with repeated java.lang.StackOverflowError on Platform Services Controller
search cancel

/var/log/vmware/sso/localhost.*.log grows to large size and filled with repeated java.lang.StackOverflowError on Platform Services Controller

book

Article ID: 318175

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:

  •  /var/log/vmware/sso/localhost.*.log grows to large size and filled with repeated java.lang.StackOverflowError on Platform Services Controller
  • In  /var/log/vmware/sso/localhost.*.log, below entries are seen:
<date> <time> SEVERE [tomcat-http--36] org.apache.catalina.core.ApplicationDispatcher.invoke
Servlet.service() for servlet appServlet threw exception java.lang.StackOverflowError
        at org.apache.catalina.core.ApplicationHttpRequest.setAttribute(ApplicationHttpRequest.java:299)
        at org.apache.catalina.core.ApplicationHttpRequest.setAttribute(ApplicationHttpRequest.java:299)
        at org.apache.catalina.core.ApplicationHttpRequest.setAttribute(ApplicationHttpRequest.java:299)
        at org.apache.catalina.core.ApplicationHttpRequest.setAttribute(ApplicationHttpRequest.java:299)
        at org.apache.catalina.core.ApplicationHttpRequest.setAttribute(ApplicationHttpRequest.java:299)
  ...
        at org.tuckey.web.filters.urlrewrite.RuleBase.matchesBase(RuleBase.java:205)
        at org.tuckey.web.filters.urlrewrite.NormalRule.matches(NormalRule.java:92)
        at org.tuckey.web.filters.urlrewrite.RuleChain.doRuleProcessing(RuleChain.java:83)
        at org.tuckey.web.filters.urlrewrite.RuleChain.process(RuleChain.java:137)
        at org.tuckey.web.filters.urlrewrite.RuleChain.doRules(RuleChain.java:144)
        at org.tuckey.web.filters.urlrewrite.UrlRewriter.processRequest(UrlRewriter.java:92)
        at org.tuckey.web.filters.urlrewrite.UrlRewriteFilter.doFilter(UrlRewriteFilter.java:394)
        at com.vmware.identity.ForwardingFilter.doFilter(ForwardingFilter.java:42)
  • Log files under /var/log/vmware/sso might fill the space in the PSC and can lead to vpxd service down on vCenter Server, hence affecting the vCenter accessibility.

Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.

Environment

VMware vCenter Server 6.7.x

Cause

This issue can occur if incompatible or outdated URL rewrite rule is written or present in web.xml for STS service.

Resolution

  1. Locate web.xml for STSService Webapp.

On Linux: /usr/lib/vmware-sso/vmware-sts/webapps/ROOT/WEB-INF/web.xml

On Windows: C:\ProgramData\VMware\vCenterServeruntime\VMwareSTSService\webapps\ROOT\WEB-INF

  1. Comment out the filter and filter-mapping for /ims/*
<!-- Disable ForwardingFilter filter.
   <filter>
       <filter-name>ForwardingFilter</filter-name>
       <filter-class>com.vmware.identity.ForwardingFilter</filter-class>
   </filter> -->
 
<!-- Disable URL rewrite for /ims/*
   <filter-mapping>
       <filter-name>ForwardingFilter</filter-name>
       <url-pattern>/ims/*</url-pattern>
       <dispatcher>REQUEST</dispatcher>
       <dispatcher>FORWARD</dispatcher>
   </filter-mapping> -->
  1. Then restart sts service using below command 
           # service-control --stop vmware-stsd
  # service-control --start vmware-stsd

Note: If above steps didn't help only then reboot the VCSA which will also help to confirm the configuration persistence status across reboot of VCSA.