Filtering for distributed switch port groups does not work in vSphere Client on vCenter Server 7.0.x
search cancel

Filtering for distributed switch port groups does not work in vSphere Client on vCenter Server 7.0.x

book

Article ID: 318151

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
When opening the "Distributed Port Groups" view for any object in vSphere Client, and trying to filter for a certain string, the table is not updated, but instead gets stuck in a "loading" status, showing a rotating circle.

Environment

VMware vCenter Server 7.0.x

Cause

The vSphere Client data service is currently not able to search for NSX Port Group IDs

Resolution

This issue is fixed in vCenter Server 8.0.
If an upgrade to vCenter Server 8.0 is not an option, the problem can be worked around by hiding the "NSX Port Group IDs" column as described below.


Workaround:

To work around this issue, the "NSX Port Group IDs" column can be set to hidden, which stops the client interface from searching in this column. To hide the column, click on the small rectangular symbol in the lower left corner of the table and deselect the check mark for NSX Port Group IDs:



After the check mark has been removed, the table is updated and shows the filtered results.