Scan for Update or Check Compliance is hung at 55% using vSphere Lifecycle Manager
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Scan for Update or Check Compliance is hung at 55% using vSphere Lifecycle Manager

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Article ID: 318016

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • Scanning the ESXi hosts using vSphere Lifecyle Manager is hung at 55% and fails with timeout
  • Issue is not seen on the hosts with the HP ams version 11.7.2.x or higher


Environment

VMware vSphere ESXi 7.x

Cause

The amsd component in the HPE custom image for May 2021 does not properly remove the ams CLI services which are no longer needed in the new release of amsd/amshelpr for ProLiant/Synergy servers.

Resolution

HPE has identified the root cause for this issue and has created a fix with the newer  HPE Agentless Management Bundle for ESXi 7.0

Workaround:
  • Log in to the vCenter server and put the host in maintenance mode
  • Log in to the host using ssh
  • Execute the below command to validate the ams version
localcli software vib list | grep -E 'amscli|amshelpr|amshelprcli'

Sample Output:
Name                           Version                             Vendor                      Acceptance Level  Install Date
-----------------------------------------------------------------------------------------------------------------------------
amscli          11.6.10.2-1OEM.700.1.0.15843807                    HPE                        PartnerSupported    2021-02-04
amshelpr        701.11.7.0.14-1OEM.701.0.0.16555998                HPE                        VMwareAccepted      2021-06-01
amshelprcli     11.6.10.2-1OEM.700.1.0.15843807                    HPE                        PartnerSupported    2021-02-04
 
  • Verify and remove the vibs from the above command output
localcli software vib remove -n <vib name>

Sample Command:
localcli software vib remove -n amscli -n amshelpr -n amshelprcli
 
  • Reboot the host