vCenter "Host Error" alarms are triggered on hosts where vmsyslog reports that it "lost xxx log messages"
Environment
VMware vSphere ESXi 7.0
Cause
This can occur when the network message buffer is filled up on ESXi and causes the messages to be dropped even though the logging volume is within the limits that vmsyslogd can handle.
Resolution
This is resolved in ESXi 7.0 Update 3o (Build 22348816)
Workaround:
Remove current remote syslog configuration
Reboot the ESXi host
Recreate the syslog configuration
Reboot again
Check functionality and logs at this point for reoccurrence.
It is also possible to disable or edit the "Host Error" alarm in vCenter for these events.