CHAP Settings May Not Persist Through Reboot When CHAP is Enabled and Configured With Dynamic Discovery on ESXi 7.0.1 and Higher Hosts
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CHAP Settings May Not Persist Through Reboot When CHAP is Enabled and Configured With Dynamic Discovery on ESXi 7.0.1 and Higher Hosts

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Article ID: 317961

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Provide a workaround to allow CHAP settings to persist through a host reboot.


Symptoms:

Issue Description : iSCSI volumes disappeared after VMware ESXi host is rebooted with CHAP enabled and configured with Dynamic Discovery on ESXi 7.0.1 and higher hosts.

This issue may be observed under these conditions.
 

  • When CHAP is enabled on the host.
  • ISCSI vmk ports are configured with dynamic discovery of iSCSI targets.


Environment

VMware vSphere ESXi 7.0

Cause

The issue is not observed in ESXi versions prior to 7.0.1

Resolution

Fix is available in ESXi 8.0a - Build 20842819 and ESXi 7.0 Update 3l - Build 21424296

Workaround:

Remove Dynamic Discovery and Configure iSCSI Storage Port With Only Static Discovery

This will have to be performed on each host in the cluster.

Place host into maintenance mode.

Navigate to the Host > Configure Tab > Storage Adapters > Highlight the iSCSI software adapter.

Navigate to the Dynamic Discovery Tab

Highlight the iSCSI Server(s) to be removed.

  • Make note of each Dynamic Discovery Target IP address.
  • Remove the Dynamic Discovery IP target(s).

Navigate to the Static Discovery Tab

  • Make note of each iSCSI Server IP and iSCSI Target name.
  • The Server IP and the iSCSI Target(s) need to be recorded as they will be added back.
  • The Server IP and the iSCSI Target(s) names can also be found on your array if there is no Static Discovery configured.
  • Highlight the iSCSI server(s) and Target Name(s) and remove.
  • Reboot the host.
Reconfigure the iSCSI targets under the static discovery only and leave the dynamic discovery blank for any target that will be configured with CHAP.

Re-scan the iSCSI software adapter and reconfigure CHAP as per your requirements.

Reboot the host and verify the retention of the CHAP settings and exit maintenance mode.


 


Additional Information

Impact/Risks:

CHAP may have to be reconfigured each time a ESXi 7.0.1 or higher host is rebooted.