SNMPD daemon failing to respond, restarts frequently on ESXi 6.5
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Article ID: 317941
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Updated On:
Products
VMware vSphere ESXi
Issue/Introduction
The purpose of this article is to resolve issue where SNMPD daemon fails to respond and restarts frequently on ESXi 6.5.
Symptoms:
After upgrading to ESXi 6.5, false alarms relating to ESXi rebooted are triggering in the SNMP monitoring station.
SNMPD daemon on ESXi 6.5 stops running on ESXi causing alarms on customers monitoring stations.
To check if snmpd process is presently running or not, use the following command: $ /etc/init.d/snmpd status snmpd is not running
In the /var/log/syslog.log , you may see similar entries:
2016-12-08T03:05:52Z snmpd: generate_ifstack: update ifstacktable - calloc 48 entries failed Cannot allocate memory 2016-12-08T03:08:20Z snmpd: load_nics: calloc ifentry for 9 ifentry failed 2016-12-05T23:12:45Z Unknown: out of memory [366441] 2016-12-05T23:13:00Z Unknown: out of memory [366441]
You may recieve a warning on ram disk full.
To verify the ram disk full, if no notification has been set, use the below command in ESXi shell : $ vdf | grep snmp snmptraps 1M 1M 0B 100% --
Environment
VMware vSphere ESXi 6.5
Cause
This issue is caused by a memory leak in the SNMPD.
Resolution
This is a known issue in vSphere 6.5.
This issue is resolved in VMware ESXi 6.5, Patch Release ESXi650-201703001.
Additional Information
Impact/Risks: When snmpd stops that causes a loss of remote telemetry to operators monitoring a vSphere ESXi but it will not not cause any loss of operational functionality.