ESXi 6.x host is disconnected from vCenter Server due to dcism exhausting inodes
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ESXi 6.x host is disconnected from vCenter Server due to dcism exhausting inodes

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Article ID: 317940

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Symptoms:
  • The ESXi 6.x host gets disconnected from vCenter Server
  • The host is running on Dell hardware 
  • It cannot connect the ESXi 6.x host to vCenter Server
  • It cannot connect to the ESXi 6.x host using the Host UI client
  • The /var/log/hostd.log file indicates that the host is out of space
  • In vmkernel.log similar entries will be shown
2019-05-08T20:57:07.588Z: [VisorfsCorrelator] 201984788713us: [vob.visorfs.ramdisk.inodetable.full] Cannot create file /etc/vmware/esx.conf.LOCK for process vsanSoapServer because the inode table of its ramdisk (etc) is full.
2019-05-08T20:57:07.926Z: [VisorfsCorrelator] 201985127158us: [vob.visorfs.ramdisk.inodetable.full] Cannot create file /etc/cim/dell/srvadmin/iSM/ini/ttttttttttttt6e4qSO for process sfcb-dcism because the inode table of its ramdisk (etc) is full.
2019-05-08T20:57:07.927Z: [VisorfsCorrelator] 201992965228us: [esx.problem.visorfs.ramdisk.inodetable.full] The file table of the ramdisk 'etc' is full. As a result, the file /etc/cim/dell/srvadmin/iSM/ini/ttttttttttttt6e4qSO could not be created by the application 'sfcb-dcism'.
2019-05-08T20:57:07.927Z: [VisorfsCorrelator] 201985127663us: [vob.visorfs.ramdisk.inodetable.full] Cannot create file /etc/cim/dell/srvadmin/iSM/ini/ttttttttttttteLupwd for process sfcb-dcism because the inode table of its ramdisk (etc) is full.
2019-05-08T20:57:07.927Z: [VisorfsCorrelator] 201992965610us: [esx.problem.visorfs.ramdisk.inodetable.full] The file table of the ramdisk 'etc' is full. As a result, the file /etc/cim/dell/srvadmin/iSM/ini/ttttttttttttteLupwd could not be created by the application 'sfcb-dcism'


Note:The preceding log excerpts are only examples.Date,time and environmental variables may vary depending on your environment

Environment

VMware vSphere ESXi 6.5

Cause

This issue occurs by the hardware monitoring service (dcism) that populates the /etc/cim/dell/srvadmin/iSM/ini directory.

Resolution

Engage with DellEMC support for a resolution with dcism vib.

Workaround:
To workaround this issue:

1.    Connect to the ESXi host using SSH.
2.    Run this command to stop the dcism service:

 /etc/init.d/dcism-netmon-watchdog stop

3. To ensure that the  dcism does not start upon reboot 

chkconfig dcism-netmon-watchdog off

4. Manually delete the files in the Check /etc/cim/dell/srvadmin/iSM/ini directory to free inodes.
  
Such as 
tttttttttttttSQfKaq
ttttttttttttt8Rcadp


5.Connect the ESXi back to vCenter if host does not come back into vCenter a reboot is required.