vSAN 7.0 Witness Appliances losing embedded license after upgrade / new deployment
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vSAN 7.0 Witness Appliances losing embedded license after upgrade / new deployment

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Article ID: 317841

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:
Deploying a new witness appliance version 7.0 released before 4/20/2020 will not have an embedded license or upgrading an existing witness appliance to vSAN 7.0, will cause the witness appliance to lose its embedded license after upgrade. In both scenarios the witness appliance defaults to a 60 day Evaluation license





Environment

VMware vSAN 7.0.x

Cause

The OVF file doesn't contain the embedded license.

Resolution

This issue has been partially fixed in 7.0 U1 but will result in an extra step of requiring to disconnect/reconnect the witness appliance as outlined in KB License status of the Witness in the vCenter UI shows as expired.

The full fix can be found in 7.0 U2 and later

Workaround:
Deploy a new witness appliance by getting the desired Version via the following steps:
1.) Log into your Account: https://support.broadcom.com/contact-support.html
2.) On the left side select "My Downloads"
3.) Select "VMware Cloud Foundation" on the upper right corner (besides your Account Name)
4.) In the Product Selection, select "VMware vSAN"
5.) Select the desired Version
6.) Select the section "Drivers & Tools"
7.) Look for desired Version of "VMware vSAN Witness Appliance"
8.) Select the arrow on the right side to expand the entry
9.) Download the desired Version

Steps to replace the witness can be found in the documentation: Change the Witness Host

For solution-based environments like VxRail/VCF, please engage the respective vendor that deployed the environment for further assistance.

Additional Information

Impact/Risks:
Once the evaluation license expires the witness will disconnect from vCenter and will not be able to reconnect.

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