Cannot re-register Compute Manager after deletion
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Cannot re-register Compute Manager after deletion

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Article ID: 317791

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Updated On:

Products

VMware NSX

Issue/Introduction

  • After deleting a Compute Manager (CM) you try to re-register the same and it fails whit the following error:

Compute Manager <IP_ADDRESS_OR_FQDN> is already registered with other NSX Manager  <IP_ADDRESS_OR_FQDN>

  • NSX Manager logs (nsxapi.log) display message(s) indicating the Compute Manager was deleted, similar to:

INFO inventoryTasksScheduler-1 ComputeManagerCleanupHandler - FABRIC [nsx@6876 comp="nsx-manager" level="INFO" subcomp="manager"] Unregistered from compute manager ComputeManagerModel [server=<server-fqdn>, externalId=null, originType=vCenter, thumbprint=<ssl-thumbprint>, originProperties=null, asymmetricCredential=null, credentialKey=null, credentialVerifier=null] and removed cm object entry from DeletedObject.

  • NSX Manager logs (nsxapi.log) display message(s) indicating the Compute Manager clean up fails, similar to:

ERROR inventoryTasksScheduler-2 ComputeManagerCleanupHandler - FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP7051" level="ERROR" subcomp="manager"] Could not clean up data for compute manager <uuid>, will be retried in next run

Environment

VMware NSX-T Data Center

Cause

When deleting a Compute Manager, due to a software issue the deletion may not complete because of stale Compute Manager dependencies.

Resolution

This issue is resolved in NSX-T 2.5.2 and NSX-T 3.0.1

Workaround:
To work around this issue if you do not want to upgrade, contact Broadcom Support.