After NSX upgrade to 3.2.0/3.2.1/4.0.0, a false alarm for "Control Channel To Transport Node Down Long" may be reported even though the actual Controller to Transport Node connection is up.
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After NSX upgrade to 3.2.0/3.2.1/4.0.0, a false alarm for "Control Channel To Transport Node Down Long" may be reported even though the actual Controller to Transport Node connection is up.

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Article ID: 317680

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Updated On:

Products

VMware NSX

Issue/Introduction

After NSX upgrade to 3.2.0/3.2.1/4.0.0, a false alarm for "Control Channel To Transport Node Down Long" may be reported even though the actual Controller to Transport Node connection is up. This could happen if there was a real Control Channel To Transport Node connection alarm before the upgrade and the actual Control Channel To Transport Node connection is resumed after the upgrade to 3.2.0.x/3.2.1.x/4.0.0 completes.

  • In the NSX-T Manager UI, the alarm "Control Channel To Transport Node Down Long" is reported. 
  • These alarms are observed for connected and working transport nodes.
  • There is no impact on the services or VMs running on the Transport Node (Host or Edge).
  • Rebooting NSX-T Managers does not resolve the alert.
  • After resolving in NSX-T Web UI manually, the Alert may appear again if Controller service is restarted
  • As per below example, the Transport Node is connected to the Managers and Controllers correctly.

[root@esxi-host:~] nsxcli -c get controllers
 Controller IP    Port     SSL         Status       Is Physical Master   Session State  Controller FQDN
  172.#.#.19     1235   enabled    connnected             true               up               NA
  172.#.#.18     1235   enabled      not used            false              null              NA
  172.#.#.17     1235   enabled      not used            false              null              NA

Environment

VMware NSX-T Data Center
VMware NSX

Cause

CCP (Central Control Plane) data migration from NSX-T Data Center 3.0.x/3.1.x to 3.2.0/3.2.1/4.0.0 release may leave conflicting records, which may generate these false alarms. 

Resolution

This issue is resolved in NSX-T Data Center 3.2.2, 4.0.1, and 4.1.0 available at Download Broadcom products and software.

Workaround:

  • Resolve the Alarm manually on NSX-T Web UI.  The alert may appear again if the Controller service is restarted and require manual resolve again.