Skyline Collector Status: ‘Partially Healthy’
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Skyline Collector Status: ‘Partially Healthy’

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Article ID: 317577

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Updated On:

Products

VMware

Issue/Introduction

Message on Skyline Advisor: “Partially Healthy: Registered Collector is not collecting data for some configured endpoints.”

Resolution

Cause:

The Skyline Collector is not collecting data from at least one of the configured products. This issue is due to one of the following reasons:
 
  1. Endpoint password has expired
  2. Endpoint configuration is changed or certificate was updated
  3. Required permissions are not assigned
  4. Unable to communicate with the endpoint on port 443

Resolution:
 
  1. Follow the steps below to check if the Endpoint password has expired, or if the configuration is changed, or the certificate was updated.
    • Login to the Skyline Collector UI by going to https://Skyline_VM_IPAddress
    • Use the admin user credentials to log in
    • Click on the ‘Configuration’ tab
    • Click ‘edit’ next to the endpoint (vCenter, Horizon, vROps, NSX) for which you are seeing an issue reported with Red exclamation
    • Update the correct credentials
      • Note: If the user used has a password policy to expire the password, request you to use an AD User and disable password expire for that User
    • Save and update the certificate thumbprint
  2. Test Communication status for endpoints:
    • Using the vSphere Client, open the remote console of the Skyline Collector virtual appliance. 
    • Log in to the console of the Skyline Collector virtual appliance with user 'root'. 
    • Execute the command: curl -v https://endpoint:443 (vCenter, Horizon, vROps, NSX)
 
  1. If the required permissions are not updated, follow the steps mentioned in KB5966.