Unable to Configure NTP in vCenter Server Appliance 6.7 VAMI
search cancel

Unable to Configure NTP in vCenter Server Appliance 6.7 VAMI

book

Article ID: 317534

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

Symptoms:
  • In the vCenter Server Appliance Virtual Appliance Management Interface (VAMI), you cannot configure an NTP server unless the NTP server replies to ICMP traffic (ping).
  • The "Edit Time Synchronization Settings" wizard displays, "<SERVER>, and <SERVER> are unreachable"
  • If trying to configure "time.windows.com" and "time.nist.gov" as NTP servers, the applmgmt.log reports messages similar to:
/var/log/vmware/applmgmt/applmgmt.log

2018-11-07T00:03:08.843 [3001]DEBUG:vmware.appliance.timesync.impl:com.vmware.appliance.ntp.test(['time.windows.com', 'time.nist.gov'])
2018-11-07T00:03:08.843 [3001]DEBUG:vmware.appliance.networking.testUtils:Testing connection to: ['time.windows.com', 'time.nist.gov']
2018-11-07T00:03:10.993 [3001]DEBUG:vmware.appliance.networking.testUtils:ping out: b'PING time.microsoft.akadns.net (51.141.32.51) 56(84) bytes of data.\n\n--- time.microsoft.akadns.net ping statistics ---\n10 packets transmitted, 0 received, 100% packet loss, time 1871ms\n\n', err: b'', returncode: 1
2018-11-07T00:03:11.100 [3001]DEBUG:vmware.appliance.networking.testUtils:ping out: b'PING ntp1.glb.nist.gov (129.6.15.28) 56(84) bytes of data.\n\n--- ntp1.glb.nist.gov ping statistics ---\n10 packets transmitted, 0 received, 100% packet loss, time 1872ms\n\n', err: b'', returncode: 1
2018-11-07T00:03:11.101 [3001]DEBUG:root:TestRunStatuses: servers=['time.windows.com', 'time.nist.gov']
 statuses=['SERVER_UNREACHABLE', 'SERVER_UNREACHABLE']
 messages=[Structure('LocalizableMessage', dict(defaultMessage='Failed to reach server.', id='com.vmware.appliance.ping.failure', args=[])), Structure('LocalizableMessage', dict(defaultMessage='Failed to reach server.', id='com.vmware.appliance.ping.failure', args=[]))]


Cause

The vCenter Server Appliance 6.7 GA and 6.7 U1 use ICMP to validate the NTP servers that have been configured.

Resolution

This issue is resolved in VMware vCenter Server 6.7 Update 2, available at My Downloads.

Workaround:
If your desired NTP servers do not respond to ICMP / ping, you can configure this using the command line.

  1. Log into the Appliance Shell as root
  2. Run the following command to set the desired NTP servers
com.vmware.appliance.ntp.set --servers SERVER1,SERVER2
  1. Run the following command to validate these NTP servers
com.vmware.appliance.ntp.get
  1. To validate NTP is running and view the offset/jitter, start by switching to the bash shell
shell
  1. Start NTP
service ntpd start
  1. Query NTP
ntpq -p
  1. Optionally, configure NTP to start automatically upon boot
systemctl enable ntpd.service