After NSX-T 3.2.0 upgrade, alarms in NSX Manager show dataplane service crashing on Edges
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After NSX-T 3.2.0 upgrade, alarms in NSX Manager show dataplane service crashing on Edges

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Article ID: 317142

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Updated On:

Products

VMware NSX

Issue/Introduction

  • After upgrading to NSX-T 3.2.0, Edges show PNIC/Bond Status 'Down', and the dataplane service is crashing constantly
  • Core files generated for dataplane crashes are named: /var/log/core/core.dp-ipcXX.XXXXXXXXX.XXXXX.X.X.g

Environment

VMware NSX-T Data Center 3.2.x

Cause

There is a "committed_bandwidth" value, which is part of QoS profiles, is used as a divisor to calculate another value.
The NSX version 3.2.0 has a data migration issue where the committed_bandwidth value can be set to 0 in NestDb, causing arithmetic errors.

Resolution

This issue is resolved in VMware NSX 3.2.0.1, available at Broadcom downloads.

If you are having difficulty finding and downloading software, please review the Download Broadcom products and software KB.


Workaround:
Detach any Gateway QoS profiles from T1 Gateways.
 
Select Networking > Tier-1 Gateways
Edit T1 Gateway and select Additional Settings
Clear any selections for Ingress QoS Profile and Egress QoS Profile Stabilize the dataplane service.

(Optional) Gateway QoS Profiles can be deleted and re-created after the upgrade, since the issue is with data migration between versions. Delete Gateway QoS profiles under Networking > Settings > Networking Profiles.