After NSX-T 3.2.0 upgrade, alarms in NSX Manager show dataplane service crashing on Edges
book
Article ID: 317142
calendar_today
Updated On:
Products
VMware NSX
Issue/Introduction
Symptoms: - After upgrading to NSX-T 3.2.0, Edges show PNIC/Bond Status 'Down', and the dataplane service is crashing constantly - Core files generated for dataplane crashes are named: /var/log/core/core.dp-ipcXX.XXXXXXXXX.XXXXX.X.X.gz
Cause
There is a "committed_bandwidth" value, which is part of QoS profiles, that is used as a divisor to calculate another value. 3.2.0 has a data migration issue where the committed_bandwidth value can be set to 0 in NestDb, causing arithmetic errors.
Resolution
This data migration issue is resolved in NSX-T 3.2.0.1
Workaround: Detach any Gateway QoS profiles from T1 Gateways. Select Networking > Tier-1 Gateways Edit T1 Gateway and select Additional Settings Clear any selections for Ingress QoS Profile and Egress QoS Profile stabilize the dataplane service.
(Optional) Gateway QoS Profiles can be deleted and re-created after the upgrade, since the issue is with data migration between versions. Delete Gateway QoS profiles under Networking > Settings > Networking Profiles.