Unable to enable HA on a cluster using vSphere Lifecycle Manager Images
search cancel

Unable to enable HA on a cluster using vSphere Lifecycle Manager Images

book

Article ID: 317076

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When enabling HA on a cluster using vSphere Lifecycle Manager Images, you encounter the following errors:

  • Cannot complete the configuration of the vSphere HA agent on the host.
  • Applying HA VIBs on the cluster encountered a failure. Failed installing HA component on the host

Environment

VMware vCenter Server 7.0.x
VMware vCenter Server 7.0.1
VMware vCenter Server 7.0.2

Cause

This issue occurs when the scratch partition is not properly configured to a disk and is instead located on the /tmp RAMdisk. The /tmp RAMdisk is subject to cleanup by tmpwatch during periods of inactivity. Critical subfolders, such as vmware/lifecycle and locker, may be removed, leading to failure during the installation of HA components on the hosts.

Resolution

Reboot the affected host. Sometimes a reboot can automatically recreate missing directories.

If that does not help, perform the following steps:

  1. Make sure impacted systems still have valid /scratch. If not, recreate the directory to something like /tmp/_osdataxxxxxx (check the /scratch symlink destination).
  2. Use the following command to recreate the directory structure:

    mkdir -p /var/vmware/lifecycle

  3. Recreate the task-status.json file with the following command:

    echo "{}" > /var/vmware/lifecycle/task-status.json

  4. Verify the existence of the following subfolders within /tmp/_osdataXXXXXX
    • cache
    • core
    • store
    • locker
  5. If any of these folders are missing, recreate them using:
     
    mkdir -p /tmp/_osdataXXXXXX/<folder_name>