Stopping and starting services on the SDDC Manager 3.x appliance fails.
search cancel

Stopping and starting services on the SDDC Manager 3.x appliance fails.

book

Article ID: 316989

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
  • Stopping or starting the services on SDDC Manager VM with the systemctl command fails.
  • You have logged in to the SDDC Manager VM as the vcf user but not switched to the root user.
  • You see a message similar to the following when attempting to start or stop a service:
Failed to stop domainmanager.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files


Environment

VMware Cloud Foundation 3.0.x
VMware Cloud Foundation 3.5.x

Cause

The standard method of logging in to the SDDC Manager VM in the 3.x release is with vcf user. Root access is required to stop or start services.

Resolution

This in expected behavior in VMware Cloud Foundation 3.x.

Workaround:
To access the root user on the SDDC Manager, do the following:
  1. Login to SDDC Manager via SSH as the vcf user.
  2. Issue the following command to switch to the root user account:
su - root
  1. Stop or start the required service with the systemctl command. For example:
systemctl stop domainmanager