The SDDC Manager UI is unresponsive when trying to expand a workload domain
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Article ID: 316885
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Updated On:
Products
VMware Cloud Foundation
Issue/Introduction
Symptoms:
The SDDC Manager UI is unresponsive when trying to expand a workload domain. A spinning blue circle is displayed indefinitely.
Attempting to query the API for healthy servers (curl -X GET http://localhost:8080/vrm-ui/api/1.0/health/getHealthyServers?maxSeverity=WARNING) returns no results and the command appears to hang.
No new activity related to the workload domain expansion is seen in the /home/vrack/vrm/logs/vrack-vrm-debug.log on the SDDC Manager Controller VM.
The vcfmanager service has recently been restarted or the SDDC Manager Controller VM has recently been rebooted.
Environment
VMware Cloud Foundation 2.3.x
Cause
After the vcfmanager service is restarted, the Health-Service component of VMware Cloud Foundation may take an excessive amount of time to initialize. No workload domain operations will be possible until this service is finished initializing.
Resolution
This is a known issue affecting VMware Cloud Foundation 2.3.x. This issue is resolved in VMware Cloud Foundation 2.3.2.6.
Workaround: To workaround this issue in VMware Cloud Foundation versions prior to 2.3.2.6, you must wait until the Health-Service is initialized before attempting any workload domain operations. You can check the status of the Health-Service on the SDDC Manager Controller VM by issueing the following command:
curl -X GET http://localhost:8080/vrm-ui/api/1.0/health/status