evosddc-debog.log grows in size rapidly causing the logs to roll-over in a matter of minutes
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evosddc-debog.log grows in size rapidly causing the logs to roll-over in a matter of minutes

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Article ID: 316870

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

Symptoms:
  • The /home/vrack/vrm/logs/evosddc-debug.log rolls over in a matter of minutes.
  • The increased logging to /home/vrack/vrm/logs/evosddc-debug.log causes large number of entries to be sent to Log Insight.


Environment

VMware Cloud Foundation 2.2.x

Cause

This is due to the incorrect entry of 'debug' rather than 'info' being set in logback.xml.

Resolution

This is a known issue affecting VMware Cloud Foundation 2.2 and 2.3. This issue is corrected in version 2.3.2.1 and higher.

Workaround:

To workaround this issue, the logging level can be manually adjusted with the following process:
  1. SSH into the SDDC Manager Controller VM (198.168.100.40) as the root user and enter the following to change to the vrack user: 
su - vrack
  1. Change directory to /home/vrack/vrm/webapps/vrm-ui/WEB-INF/classes/
  2. Take a backup of the logback.xml file:
cp logback.xml logback.xml.old
  1. Open the logback.xml file with a text editor, then locate and edit the following line:
<logger name="org.springframework.beans" level="DEBUG">
  1. Change "DEBUG" to "INFO".
  2. Save and close the file.
  3. Type exit to switch back to the root user.
  4. Run the following to restart the vcfmanager service:
systemctl restart vcfmanager