vertica.log keeps growing in size on the CA Performance Management (CAPM) Data Repository (DR)
search cancel

vertica.log keeps growing in size on the CA Performance Management (CAPM) Data Repository (DR)

book

Article ID: 31680

calendar_today

Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

The ~/catalog/drdata/v_drdata_node0001_catalog/vertica.log log keeps growing and fills up the space in the partition. The vertica database is down as there is no more space left in the partition.

Environment

DX NetOps CAPM all releases

Cause

The log rotation is not enabled for vertica.log

Resolution

Log in to the database server for Data Repository as the database administrator user. Type the following command:

su - dradmin

Type the following command:

/opt/vertica/bin/admintools -t logrotate -d <db name> -r <HowOften> -k <number of weeks>

Example

/opt/vertica/bin/admintools -t logrotate -d drdata -r daily -k 3

-d indicates the database name
-r indicates how often to rotate the logs (daily, weekly, monthly).
-k indicates the number of weeks to keep the log.

Data Repository log rotation is now set up to occur daily, and only three weeks of log files are maintained.

These steps are mentioned in the installation guide and therefore can be done just after vertica installation.