[VMC on AWS] Unable to perform HCX migration with the error "External device(s) detected on VM-name."
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[VMC on AWS] Unable to perform HCX migration with the error "External device(s) detected on VM-name."

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Article ID: 316689

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

This article provides information how to fix "External device(s) detected on VM-name." error on your HCX UI.

Symptoms:
You are unable to perform HCX migration such as vMotion and Bulk Migration from HCX plugin UI with the following errors.

One or more VMs have errors, cannot proceed with migration.
External device(s) detected on VM-name.


Cause

This issue is caused by the state of VM's drive configuration.

Resolution

Please check your Virtual Hardware settings on your VM from vSphere Client.
  • Verify that "Connected" option is disabled if external device such as "CD/DVD drive" is in the setting.
  • Verify that "Connect At Power On" status under the external device is disabled.
  • Also, you can configure this setting by using PowerCLI.
1. Run the following command to connect your vCenter in a PowerCLI.

Connect-VIServer -Server <vCenter FQDN or IP> -User [email protected] -Password <password> -force

2. Run the following command to disable "CD/DVD drive" from the VM.

get-vm -Name <VM Name> | get-cddrive | Set-CDDrive -StartConnected $false

If the VM is in your VMware Cloud on AWS SDDC, please see following instructions to connect to SDDC vCenter by using PowerCLI.

PowerCLI 12.0.0 User’s Guide - Sample Scripts for Managing VMware Cloud on AWS with VMware PowerCLI
 
  • If the problem persists after the above measures, please remove the "CD/DVD drive" from the following and check for improvement.
    • vSphere Client > Hosts and Clusters > VM-name > ACTIONS > Edit Settings > Click the "X" on the right side of the "CD/DVD drive" to remove.