NSX-T v2T config import is failing with "Distributed Firewall failed with 'list index out of range'"
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NSX-T v2T config import is failing with "Distributed Firewall failed with 'list index out of range'"

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Article ID: 316676

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • The Migration coordinator import is failing with the message: "Distributed Firewall failed with 'list index out of range'"
  • The same message can be found in the NSX-T Manager log: /var/log/migration-coordinator/v2t/summary.log
"stage": "xlate",
    "status": "error",
    "api_count": 2478,
    "feedback_requests_count": 64,
    "errors": [
        {
            "category": "Unexpected error",
            "error": "Distributed Firewall failed with 'list index out of range'"
        }
    ],
  • There is no high usage of the NSX-V CPU during the migration import is running.
  • In the NSX-T Manager log the following entry can be seen: /var/log/migration-coordinator/v2t/collection.log
021-05-25 14:46:50,398 __main__     DEBUG    Collecting /api/2.0/nwfabric/status/alleligible/clusters
Failed to GET https://<NSX-v.FQDN>/api/2.0/nwfabric/status/alleligible/clusters with status: 400 and reason: <?xml version="1.0" encoding="UTF-8"?>
<error><errorCode>859</errorCode><details>Error occurred while communicating with EsxAgentManager.</details><moduleName>core-services</moduleName></error>


Environment

VMware NSX Data Center for vSphere 6.4.x
VMware NSX-T Data Center

Cause

NSX-v Manager cannot communicate with the EAM Service running on vCenter.

Resolution

Ensure NSX-v Manager can communication with the vCenter service called EAM.
The EAM service status can be check on the NSX-v plugin of vCenter.

If you need assistance on restoring the EAM service, please raise a Support Request to VMware Global Support.

Additional Information

Impact/Risks:
The v2T migration import cannot complete.