Trend Micro SVM starts without IP address
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Trend Micro SVM starts without IP address

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Article ID: 316663

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms:
  • After rebooting the Trend Micro SVM, the SVM boots without IP address.
  • If you put the host in maintenance mode and remove it from maintenance mode, the SVM is boots without IP address.
  • The IP pool still have available IPs.
  • If the Trend Micro SVM was redeployed it gets an IP from the pool
    • Redeploying the Trend Micro SVM by deleting the SVM and pressing on Resolve under the service deployment menu.
  • Running the following command in the SVM console should return empty management.ip0 value:
    • vmtoolsd --cmd “info-get guestinfo.ovfenv
    • image.png


Environment

VMware NSX for vSphere 6.4.x

Cause

Trend Micro uses custom property called 'management.ip0' as Service attribute. That property has "empty string" as value. NSX also define native property with same name and injected in OVF.

NSX V always uses latest value define by partner service attribute, whenever a SVM is reconfigured.

In this case, the Trend value is "empty string". This value will be overwritten to NSX based injected static IP. Trend uses 'management.ip0' to configure static IP and in this case it will be empty string, leading to lost of IP.

Resolution

This issue has been fixed in 6.4.11

Workaround:
Either of the following methods should be a work around:
  1. Method 1:
    • Assign the IPs manually from within the SVM:
      • Using vSphere Client, log on to the vCenter.
      • Select the SVM and click the Console tab.
      • Log in to the appliance by pressing F2 and entering the default username “dsva” and password “dsva”.
      • Select Configure Management Network from the menu and press ENTER.
      • Change the values of the following entries to match that of your network:
        • Hostname
        • IP address
        • Netmask
        • Gateway
        • DNS
      • Press ENTER to save the changes.
  2. Method 2.
    • Redeploying the Trend Micro SVM by deleting the SVM and pressing on Resolve under the service deployment menu.


Additional Information

Impact/Risks:
Trend Micro SVM wont work as expected due to its unreachability