During the v2T migration, the import configuration stage encounters a failure with a "Server error from NSX-V Manager for /api/4.0/firewall/globalroot-0/clusters" Please retry config collection.
search cancel

During the v2T migration, the import configuration stage encounters a failure with a "Server error from NSX-V Manager for /api/4.0/firewall/globalroot-0/clusters" Please retry config collection.

book

Article ID: 316300

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

During an NSX v2T Migration, the import configuration stage encounters a failure with a "Server error from NSX-V Manager for /api/4.0/firewall/globalroot-0/clusters" Please retry config collection.

Example Screenshot:


  • On the NSX-V Ui, under Transport Zone settings for the host, an internal server error is thrown in the UI.

Example Screenshot:

  • On the NSX Manager and the MC logs we see the following:

vsm log:

####-##-####: GMT ERROR http-nio-127.0.0.1-7441-exec-177 RemoteServerUtil:121 - - [nsxv@6876 comp="nsx-manager" level="ERROR" subcomp="manager"] Throwing remote base exception
com.vmware.vshield.vsm.remoting.server.exceptions.RemoteBaseException: Internal server error has occurred.
at com.vmware.vshield.vsm.remoting.server.util.RemoteServerUtil.convertException(RemoteServerUtil.java:114) [vsm-core-1.0.jar:?]

Migration co-ordinator Log:

####-##-####: _main_ ERROR Server error from NSX-V Manager for: /api/4.0/firewall/globalroot-0/clusters. Please retry config collection.
Starting config validation
Configuration validated successfully
STATUS: error

ERROS: 'NSX-V collector','error': 'Server error from NSX-V Manager for: /api/4.0/firewall/globalroot-0/clusters. Please retry config collection'}


Environment

VMware NSX Data Center for vSphere

Cause

This issue arises because of an incorrect entry in the vxlan feature for the hosts that were prepared for NSX-V, therefore requiring a database action for resolution.

Resolution

Given that there are no more releases for NSX-V hence a resolution won't be pursued, kindly refer to the workaround provided in the following section to address this problem and assist the customer.

Workaround:
Attempt the following database actions:

  • Verify the status of vteps on hosts displaying error_status for the vxlan feature.
  • If all appears well, proceed to reset the error message and error status for these hosts.

Verification:

Verify the vteps on hosts displaying error_status for the vxlan feature using the query below in the NSX database:

#select * from nwfabric_resource_status_feature_status where resource_status like 'host%' and feature_id like 'com.vmware.vshield.vsm.vxlan%' and error_status != '';

Examine the host status for all hosts listed in the query result above to ensure their status is good by using the query below:

#select * from xvs_host_info inner join xvs_vmknic_info on xvs_host_info.id=xvs_vmknic_info.host_id where xvs_host_info.host_id='<host-id>';

To verify the status of the vtep on the host from the above output.
- Ensure that the vmknic_device_id contains a valid vmk ID, such as "vmk4."
- Confirm that the allocated_ip_id is set to '-1.'
- Verify that the missing_on_host parameter is set to 'f.'

Reset:

Upon confirming that all hosts look good, the error message and error status for these hosts can be reset with the following query:

#update nwfabric_resource_status_feature_status set message = '', error_status = '' where resource_status like 'host%' and feature_id like 'com.vmware.vshield.vsm.vxlan%' and error_status != '';


After completing these steps, refreshing the NSX-V UI will eliminate the internal server error. You can then resume the v2T migration process.

Additional Information

Impact/Risks:
Unable to proceed with the migration until the issue is resolved.