Updating licenses for a SDDC Manager Workload shows insufficient licenses error.
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Updating licenses for a SDDC Manager Workload shows insufficient licenses error.

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Article ID: 316071

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

This article allows users to understand that there is a calculation issue for the available no of licenses causing incorrect quantity and error alert to appear. Also, this article provides steps on how to remediate from the problem.

Symptoms:
When the 'Update Licenses' operation is performed for a Workload Domain, in certain cases, incorrect quantity of licenses is shown in the 'Available quantity' field (could be negative as well) for VSAN or ESXI products.

This is due to a miscalculation in the no. of available licenses. Along with the incorrect quantity, an error alert might also be displayed saying 'License key has insufficient license'.

Environment

Vmware Cloud Foundation 5.1
VMware Cloud Foundation 5.0

Cause

Miscalculation in the code for quantity of available licenses which is causing the error alert to appear.

Resolution

The issue has been fixed in VMware Cloud Foundation 5.1.1 release.

Workaround:
The users can simply choose to ignore the incorrect license count in the 'Available quantity' field when assigning the license.

Also, the error alert should be ignored as it does not prohibit the user from moving forward. Users can proceed with the addition of license even with the error alert. If there are sufficient licenses available, the operation would succeed.