SOS Support Bundle creation fails post SDDC-Manager Backup and Restore.
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SOS Support Bundle creation fails post SDDC-Manager Backup and Restore.

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Article ID: 316050

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Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

The SOS Support Bundle creation operation status API gives the error "ID_NOT_FOUND".

 

Environment

Vmware Cloud Foundation 5.1

Cause

When the SDDC-Manager backup operation and the SoS log collection operations are performed simultaneously, there can be a chance that the Backup operations may backup some files that are related to the Sqlite sos db write lock file. When the SDDC-Manager is restored using this backup file, the write lock is acquired on the Sqlite db which does not allow the new writes.

Resolution

Currently,there is no resolution.

Workaround:

Restart the 'sosrest' service.

  1. SSH into the SDDC Manager with vcf user
  2. Switch the user to the root
    su -
  3. Restart the 'sosrest' service.
    systemctl restart sosrest
  4. Verify if the service is active:

    systemctl status sosrest
  5. Retry the SOS bundle generation.