SDDC Manager Pre-Check Fails for “Cluster Inventory Sync Check” with the error – “Cluster Mor id cannot be null or empty”
search cancel

SDDC Manager Pre-Check Fails for “Cluster Inventory Sync Check” with the error – “Cluster Mor id cannot be null or empty”

book

Article ID: 316008

calendar_today

Updated On:

Products

VMware Cloud Foundation VMware SDDC Manager / VCF Installer

Issue/Introduction


While running the SDDC Manager pre-checks, the pre-checks fail for “Cluster Inventory Sync Check” with the error – “Cluster Mor id cannot be null or empty”.


Environment

  • VMware Cloud Foundation
  • VMware SDDC Manager

Cause

If vSphere cluster create workflow fails because of any reason, the VCF inventory will not have source_id populated for the cluster.

Resolution

  1. Take snapshot of SDDC Manager VM
  2. SSH to SDDC Manager using vcf and su to root
  3. Connect to platform database and fetch the cluster details
    psql -h localhost -U postgres -d platform -c "\x" -c "select * from cluster"


    Sample output:




    Note: source_id is blank

  4. Login to vCenter GUI, navigate to the cluster and note the “source_id”(ClusterComputeResource) from the URL



  5. Update the “source_id” in SDDC Manager cluster table in platform database
    psql -h localhost -U postgres -d platform -c "update cluster set source_id=’<source id gathered from step # 4>’ where id=’<id from step # 3>’"
  6. Run the pre-checks in SDDC Manager.




Additional Information

Impact/Risks:
SDDC Manager can't load any of the clusters, due to which we can't continue with any of the upgrades.