Resetting the admin password via CLI in vRealize Log Insight 4.7 fails
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Resetting the admin password via CLI in vRealize Log Insight 4.7 fails

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Article ID: 315937

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • When running the reset admin password script, li-reset-admin-passwd.sh, via CLI you get the below error:
Connection error: ('Unable to connect to any servers', {'127.0.0.1': AuthenticationFailed('Remote end requires authentication.',)})
ERROR: unable to get salt


Environment

VMware vRealize Log Insight 4.7.x

Cause

The password script fails to login to the Cassandra database in vRealize Log Insight 4.7 because of authentication being required in this version. The default li-reset-admin-passwd.sh script does not attempt to authenticate against Cassandra, thus it fails to reset the password.

Resolution

Follow the below steps to reset the admin user's password in vRealize Log Insight 4.7:
  1. Download the file li-reset-admin-passwd-47.sh attached to this KB. 
  2. Via SCP or SFTP as root to the vRealize Log Insight nodes, copy the file li-reset-admin-passwd-47.sh to /opt/vmware/bin/.
  3. SSH as root to the corresponding vRealize Log Insight nodes and change the permissions to 755 by issuing the command chmod 755 /opt/vmware/bin/li-reset-admin-passwd47.sh.
  4. Run the new script by issuing the command /opt/vmware/bin/li-reset-admin-passwd-47.sh on a vRealize Log Insight node.
  5. The script will output a temporary admin password that can be changed once logged into the product UI.


Additional Information

How to Access the Cassandra Database in vRealize Log Insight 4.7 and later
Reset the Admin User Password

Attachments

li-reset-admin-passwd-47.sh get_app