Upgrading to vRealize Log Insight 8.x hangs on "A start job is running for dev-sda4.device"
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Upgrading to vRealize Log Insight 8.x hangs on "A start job is running for dev-sda4.device"

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Article ID: 315926

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • When upgrading vRealize Log Insight to 8.0-8.2, you see this message displayed in a vSphere Web Client Console to the Log Insight appliance
A start job is running for dev-sda4.device
  • The job runs indefinitely and never finishes


Environment

VMware vRealize Log Insight 8.x

Cause

This occurs because the upgrade to Photon OS renames sda partitions to another name, such as sdc, sdd, or sde, but the VM tries to boot to the originally configured sda4 partition.

Resolution

This issue is resolved in Log Insight 8.3, and should require no manual intervention.  If you find this is not the case, please file a support request with VMware Technical Support.

Workaround:
To work around this issue:

1. Reboot the VM from vCenter and open a console immediately
2. When available Operating Systems are listed, select Photon with your arrow keys and enter rd.break=pre-mount at the end of Boot Options. Press enter.
3. When you reach the pre-mount:/# prompt, type ls /dev 
4. Observe the list and find the disk which has all 4 partitions, like sdc1, sdc2, sdc3, sdc4 (it will be anything other than sda, since you are observing this issue). This means sda partition has been renamed to sdc (or sdd, sde).
5. Run the following commands in sequence:

mkdir temp-dir
mount /dev/sdc1 temp-dir
sed -i "s/sda4/sdc4/" temp-dir/boot/grub/menu.lst
umount /dev/sdc1
mount /dev/sdc4 temp-dir
sed -i "s/sda/sdc/" temp-dir/etc/fstab
 
Note: In the above commands, replace sdc with the disk which you identified in step 4 to have all 4 partitions (if different than sdc).

11. From vCenter, reboot the VM and from a console, be sure to select Photon from the boot options 
 
Notes: In a single node cluster, this will resolve the issue. In a multi-node cluster, if the issue occurred on the primary node or a middle worker node (not the last mode in the upgrade list) the upgrade will not continue for the remaining worker nodes. In that instance, upgrade the node(s) manually using this article:How to Manually Upgrade vRealize Log Insight via Command Line (83225)

If you encounter the original issue on other nodes in the cluster, perform steps 1-11 on them as well.
 


Additional Information