Using vIDM to access vRealize log Insight in vRealize Operations Manager
search cancel

Using vIDM to access vRealize log Insight in vRealize Operations Manager

book

Article ID: 315907

calendar_today

Updated On:

Products

VMware Aria Suite

Issue/Introduction

Accessing the vRealize Log Insight interface from the vRealize Operations Manager UI when authenticating via VIDM requires certain configurations in order to be redirected properly.

Symptoms:
  • The vRealize Log Insight deployment has a FQDN associated to 1 or more nodes.
  • The vRealize Log Insight deployment has one or more VIPs with associated FQDNs associated to 1 or more nodes.
  • The Launch in Context integration option is enabled.


Environment

VMware vRealize Log Insight 4.6.x
VMware vRealize Operations Manager 6.7.x
VMware vRealize Log Insight 4.5.x
VMware vRealize Operations Manager 6.6.x
VMware vRealize Operations Manager 6.5.x

Cause

vReliaze Log Insight always pushes its FQDN into vRealize Operations Manager, so the Log Insight tab on the home page of vRealize Operations Manager will always attempts to access vRealize Log Insight via FQDN.

Resolution

For vIDM users to be redirected correctly, complete the following:

In vRealize Log Insight

  1. Log into vRealize Log Insight as admin.
  2. Navigate to Administration > Authentication.
  3. Click Enable Single Sign-On to turn it on.
Note: If you have a valid VIDM Authentication source, skip step 4, and instead, edit the existing source.
  1. Create a VIDM authentication source with the required information.
  2. Specify the Redirect URL Host.
Note: It's recommended to use a VIP for the redirect URL.
  1. Click Save.
  2. Navigate to Administration > vRealize Operations.
  3. Input the required information and check Enable launch in context, test the connection and Save.
 

In vRealize Operations Manager

  1. Log into vRealize Operations Manager as admin.
  2. Navigate to Administration > Access > Authentication Sources.
  3. Click Add.
Note: If you have a valid VIDM Authentication source, skip 4, and instead, Edit the existing source.
  1. Create a vIDM authentication source with the required information.
  2. Specify the Redirect FQDN/IP.
Note: This should match the address used in step 8 in the above section.
  1. Click OK.
  2. Navigate to Administration > Solutions.
  3. Select the VMware vRealize Log Insight solution and click Configure.
  4. Configure a Log Insight adapter instance; for Log Insight server use the same address used instep 4.
  5. Click Save Settings, then Close.
  6. Navigate to Administration > Configuration > Inventory Explorer.
  7. Filter for loginsightlogserverhost.
  8. Select the loginsightlogserverhost object and click Edit Object.
  9. Replace the FQDN in the HOST field with the IP address translation.
  10. Click OK.


Additional Information

Notes: If the vRealize Log insight deployment has no associated FQDNs or VIPs, the integration will work without using the steps in the Resolution section.

If Launch in context (step 8 in the first section) is ever unchecked and rechecked, the HOST address must be updated again (step 14 in the second section).

If vIDM is being used, please use the format of username@domain@authSource where authSource is the friendly name of the vIDM authentication source, as defined in the product where it is configured.