How to clear the Expired Certificates banner in Aria Operations
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How to clear the Expired Certificates banner in Aria Operations

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Article ID: 315906

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Upon logging into the Product UI of Aria Operations, you see a banner across the top stating that there are expired certificates, with a link directing you to the Administration > Control Panel > Trusted Certificates (Administration > Certificates in versions below 8.18.x) section of the UI with the following possible text:

  • "Your certificate is expired. Please check the expiry date to take an action."

Environment

Aria Operations 8.x
vRealize Operations 8.x

Cause

The presence of this banner indicates that you have previously trusted certificates within Aria Operations that have expired.

Resolution

To resolve this issue:

  1. Ensure you are logged in with an admin-level account.
  2. Click the link in the banner, or navigate to Administration > Control Panel > Trusted Certificates (For Aria Operations versions below 8.18 navigate to Administration > Certificates)
  3. Sort by the Expires column, and note which certificates are expired, as well as what endpoint they were issued to.
  4. Make note of the Certificate you are deleting. Is the certificate from a Management Pack or an Authentication Source?
  5. Delete the expired certificate(s).
  6. Note: If the following pop-up "Confirmation" window shows up when trying to delete the certificate, click "NO". Then proceed with the steps below. 
     

If the certificate is from a Management Pack:

  1. Navigate to Administration > Integrations (Data Sources > Integrations in older versions). 
  2. Expand the Account instances until you find those correlated to the expired certificates identified in Step 3 above.
  3. Click the ellipsis, then Edit, followed by Validate Connection.
  4. Accept the new certificate if it is presented, and then click OK then Save.
  5. Delete the expired certificate.
  6. Note: If the above steps still do not delete the expired certificate, the workaround is to make note of the configurations of the accounts under the Management Pack(s). Then delete the accounts without deleting related objects. Then delete the expired certificate. Then add the accounts back to the Management Pack. 

 

If the certificate is from an Authentication Source:

  1. Navigate to Administration > Control Panel > Authentication Sources (Administration > Authentication Sources in older versions)
  2. Click the ellipsis then Edit
  3. Click on Test.
  4. Accept the new certificate if it is presented, and then click OK.