Stale notifications are not being cleared in the Smarts SAM Notification Log Console
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Stale notifications are not being cleared in the Smarts SAM Notification Log Console

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Article ID: 315800

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Updated On:

Products

VMware Smart Assurance

Issue/Introduction

  • How to check the status of SAM Event Driver
  • Stale notifications are not being cleared in the Smarts SAM Notification Log Console
  • Notifications EventState=ACTIVE in the Notification Properties dialog but the actual event is cleared in the underlying domain

Environment

VMware Smart Assurance - SMARTS

Cause

Restarting the Event Driver, Smarts SAM domain should re-synchronize all the CLEAR events that were missed during disconnect with underlying domain.  

If this is happening there may be performance issues that need to be addressed.

Resolution

 For an immediate workaround, restart the Smarts SAM Event Driver as follows:
  1. To get the status of Event Driver, run the following command:

         ./dmctl -s <SAM> get GA_DaemonDriver::<DOMAIN>_Event-Driver::state

    This command should return GA_DRIVER_RUNNING
  2. Stop the event driver as follows:

         ./dmctl -s <SAM> invoke GA_DaemonDriver::<AM>_Event-Driver stop
  3. Run the state command from the step 1 again and wait until state = GA_DRIVER_RUNNING changes to state = GA_DRIVER_STOPPED
     
  4. Start the event driver as follows:

    ./dmctl -s <SAM> invoke GA_DaemonDriver::<AM>_Event-Driver start
  5. Verify if Event Driver is running again as follows:

    ./dmctl -s <SAM> get GA_DaemonDriver::<AM>_Event-Driver::state  

    This command should again return GA_DRIVER_RUNNING.