How To Troubleshoot SNMP walk errors such as VarBind errors
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How To Troubleshoot SNMP walk errors such as VarBind errors

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Article ID: 315734

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Updated On:

Products

VMware Smart Assurance VMware Telco Cloud Service Assurance

Issue/Introduction

VarBind error received while runing sm_snmpwalk in Smarts IP environment

 

Environment

Smarts 10.X / 2.X

Cause

The types of problems that can cause a walk error are: 

  • Wrong data types being places into an OID VarBind pair
  • Value for the oid that is out of the data types range, a value that is so large it causes the snmp agent buffer to overflow.

Resolution

To troubleshoot a VarBind error and other errors received when running a SNMP walk on a Smarts IP environment, run the walk with the dump and debug options.  Use the following command options on the snmp walk and run the walk using SNMPv1:

<BASEDIR>/IP/smarts/bin/sm_snmpwalk --timeout=60000 -d -D -c (community string) -s 1 (device IP) 2> (device IP)_troubleshoot.txt

This will produce 6 files, the standard walk files (*.walk, *.mimic, *.snap, timeout_<device>.log) as well as a packet trace for the snmpwalk (*.dump) and any output to the screen in (device IP)_troubleshoot.txt. 

The files of interest will be the dump file and the troubleshoot file. These files will contain any errors that the walk encountered. Search through the troubleshoot file looking for the word error.  There will be OIDs associated with the errors that will help you determine which OID is causing the problem and the actual issue. You can then match the oids you find with errors to oids in the *.dump file to get more information about the problem.