Hosts are not showing disk groups as mounted under Configuration > Disk Management.
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Hosts are not showing disk groups as mounted under Configuration > Disk Management.

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Article ID: 315531

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Updated On:

Products

VMware vSAN

Issue/Introduction

Symptoms:
  • Disk group(s) are not visible in WebClient Configuration > Disk Management, getting disk details fail when using esxcli commands and RVC doesn't show disks_status.
  • Restarting the vSAN Health service in vCenter and the vsanmgmtd service on the affected ESXi host only temporarily resolves the issue.



Environment

VMware vSAN 6.6.x
VMware vSAN 6.x
VMware vSAN 6.7.x

Cause

The vCenter Database contains stale entries.

Resolution

Not determined 

Workaround:
To resolve this issue, restart the “vsan-health” service in vCenter and the vsanmgmt service on all ESXi hosts in the affected cluster.

To restart the vSAN Health Service, run these commands:

1. Log in to the vCenter Server Appliance using SSH.
2. Activate Bash Shell.

service-control --stop vmware-vsan-health
service-control --start vmware-vsan-health

To restart the vSAN management service on an ESXi host, log in using SSH and run this command:

/etc/init.d/vsanmgmtd restart