"LDAP error: No such Object" error when upgrading from vCenter Server 5.5 to 6.x/7.0.x/8.0.x
search cancel

"LDAP error: No such Object" error when upgrading from vCenter Server 5.5 to 6.x/7.0.x/8.0.x

book

Article ID: 315402

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

This article is also applicable for the migration from the vCenter Server 5.5 to VCSA 6.5/7.0 and 8.0 as well

Symptoms:
  • During the vCenter Server 6.x upgrade the following errors are seen:
    • LDAP error: No such Object
    • Error in creating new service entity machine
    • Installation of component VCSServiceManager failed with error code '1603'. Check the logs for more details.
       
  • The install_drive:\\ProgramData\VMware\vCenterServer\logs\vmdird\vmdir.log contains entries similar to:

    <YYYY-MM-DD>T<time>:t@8246016:INFO: Add Entry (CN=machine-########-####-####-####-########6847,CN=ServicePrincipals,DC=vsphere,DC=local)
    <YYYY-MM-DD>T<time>:t@8246016:INFO: Modify Entry (CN=SolutionUsers,DC=vsphere,DC=local)
    <YYYY-MM-DD>T<time>:t@8246016:INFO: Modify Entry (CN=ComponentManager.Administrators,DC=vsphere,DC=local)
    <YYYY-MM-DD>T<time>:t@8246016:INFO: Modify Entry (CN=SystemConfiguration.Administrators,DC=vsphere,DC=local)
    <YYYY-MM-DD>T<time>:t@8246016:ERROR: InternalModifyEntry: VdirExecutePostModifyCommitPlugins - code(9703)
    <YYYY-MM-DD>T<time>:t@8246016:ERROR: VmDirSendLdapResult: Request (102), Error (32), Message (BEEntryModify (9703)((MDB_NOTFOUND: No matching key/data pair found)(cn=administrators,cn=builtin,dc=vsphere,dc=local))), (0) socket ([2060] vcenter_ip:389<-vcenter_ip:50769)</time></time></time></time></time></time>


Environment

VMware vCenter Server Appliance 6.0.x
VMware vCenter Server 7.0.x
VMware vCenter Server Appliance 6.5.x

VMware vCenter Server 8.0.x

Cause

The vSphere 6.X upgrade requires that the [email protected] user is added to a group in the builtin container in vmdir.

Resolution

To resolve this issue, add the [email protected] account to the DC Admins group.

Process to add the [email protected] account to the DC Admins group:

  1. Log into the Web Client as the [email protected] account.
  2. Click Administration.
  3. Click Users and Groups under Single Sign-On.
  4. Select the Groups tab select DC Admins.
  5. In the bottom pane under Group Members click the button to add a member.
  6. Add the [email protected] account.


Additional Information