Selecting network range results empty list when using third party IPAM provider
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Selecting network range results empty list when using third party IPAM provider

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Article ID: 315398

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Symptoms:
  • Issue with third-party IPAM providers in which a query can time out when returning Network Ranges, resulting in an empty list.
  • Typically observed when using a large number of networks.


Environment

VMware vRealize Automation 7.3.x
VMware vRealize Automation 7.2.x
VMware vRealize Automation 7.0.x
VMware vRealize Automation 7.1.x

Cause

This issue occurs when large number of network ranges takes too long to return query which results in timeout.

Resolution

This is a known issue affecting vRealize Automation 7.x
 
Currently, there is no resolution.
 
To work around this issue, use one of these options:
 
  • Provide search criteria to avoid the timeout and obtain the network range information.

    For example:
     
    • You can add a custom attribute named VLAN to each network with a corresponding value, such as 4. You can then filter on the VLAN=4 string in the network ranges option on the vRealize Automation network profile page.
    • Depending on your IPAM provider, add a property named VLAN to each network in the IPAM provider application and assign a value to that property, such as 4. You could then filter on the property and value, for example VLAN=4, in the Select Network Range text box on the vRealize Automation network profile page.
       
      Note: The example is Infoblox specific, VLAN=4 works for Infoblox, but might not work for other IPAM providers.
       
  • Increase the timeout setting:
     
    1. Open the /etc/vcac/webapps/o11n-gateway-service/WEB-INF/classes/META-INF/spring/root/o11n-gateway-service-context.xml file of the vRealize Automation appliance node.
       
    2. Search for the vco.socket.timeout.millis timeout key:

      <property name="socketTimeout" value="#{vcoConfig['vco.socket.timeout.millis']?:30000}"/>

      Note: A value of 30000 is a timeout of 30 seconds.
       
    3. Change the vco.socket.timeout.millis timeout value from 30 seconds to a higher number.
       
    4. Restart vcac-server service by running the command:

      service vcac-server restart