The VM Fails to Power On Due to "System Cannot Find the File Specified" or Other "File Not Found" Errors
search cancel

The VM Fails to Power On Due to "System Cannot Find the File Specified" or Other "File Not Found" Errors

book

Article ID: 315391

calendar_today

Updated On: 03-02-2025

Products

VMware vSphere ESXi

Issue/Introduction

This article provides solutions for situations where a virtual machine (VM) fails to power on due to missing or invalid virtual machine disk (VMDK) descriptor files or snapshot chain issues.

Symptoms:

  • The virtual machine cannot power ON and reports errors about missing files or disk dependencies. The error typically involves missing VMDK descriptor or data files, or an inconsistent snapshot chain.
  • The errors typically encountered include:

    "Cannot open the disk '/vmfs/volumes/volume/vm/vm-000002.vmdk' or one of the snapshot disks it depends on."
    "Cannot open disk '/vmfs/volumes/volume/vm/vm-000002.vmdk': The parent virtual disk has been modified since the child was created (18)."
  • The following error can be seen in the vSphere Client > VM > Monitor > All Issues: "Some of the disks of the virtual machine vm_name failed to load. The information present for them in the virtual machine configuration may be incomplete."

Issue validation:

  • In the VM's vmware.log, messages similar to below can be seen:
    vmx| DISKLIB-LINK : "myvm.vmdk" : failed to open (The system cannot find the file specified).
    vmx| DISKLIB-CHAIN : "myvm.vmdk" : failed to open (The system cannot find the file specified).
  • On validating the files in the VM folder, one or more disk descriptor or data files are missing.

Environment

VMware vSphere ESXi 6.x
VMware vSphere ESXi 7.x
VMware vSphere ESXi 8.x

Cause

These errors can occur due to:

  • Missing or corrupted virtual machine disk (VMDK) descriptor or data files.
  • Inconsistent snapshot chains where a child disk depends on a missing or modified parent disk.

Resolution

Note: The below steps can be destructive, kindly ensure valid backup for VM is available before proceeding.

Steps to Resolve "File Not Found" Errors When Powering On a VM:

  1. Verify the presence of Virtual Machine Disk Files

  2. For each disk, including snapshot disks, verify that the following files are present:

    1. Base Disk Descriptor File: vmName.vmdk

    2. Base Disk Data File: vmName-flat.vmdk or vmName-separse.vmdk

    3. Snapshot Disk Descriptor File: vmName-######.vmdk for each snapshot.

    4. Snapshot disk data file: vmname-######-delta.vmdk or vmname-######-sesparse.vmdk for each snapshot.  

    5. If any of these files are missing, the disk may need to be recreated or restored.

  3.  Recreate Missing Descriptor File:

    1. Base Disk Descriptor File: If the descriptor file for the base disk is missing, it can be recreated. To do so, follow KB - Recreating a missing VMware virtual machine disk descriptor file (.vmdk).

    2. Snapshot Disk Descriptor File: If the descriptor file for a snapshot disk is missing, follow KB - Recreating a missing virtual disk (VMDK) descriptor file for delta disks.

  4.  Missing Data File:

    1. If data files, such as -flat.vmdk-delta.vmdk, or -sesparse.vmdk files are missing, the VM may need to be restored from a backup or the original data source.

  5. Check for Inconsistent Snapshot Chains: 

    1. If errors regarding "The parent virtual disk has been modified since the child was created" is encountered it may be needed to consolidate the snapshot chain or restore the VM from a backup.

Additional Information