Unable to Save Proxy Information via VAMI "HTTPS Proxy Server Unreachable"
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Unable to Save Proxy Information via VAMI "HTTPS Proxy Server Unreachable"

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Article ID: 315234

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

The Purpose of this document is to save time troubleshooting the network connectivity issues to the customer proxy server

Symptoms:
  • You will not be able to grab URL Updates inside the VAMI interface.
  • When you try to ping the Proxy Server from within vCenter using SSH, you will receive "Packet Filtered" Message:
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  • When you try to edit any of the HTTP / HTTPS values inside Networking Section, you end up with an error
"HTTP/HTTPS Proxy server unreachable"

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  • Telnet connections to the proxy server are successful.
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  • setting a proxy via /etc/sysconfig/proxy will not resolve the issue.
  • If HTTP is used, setting the proxy server via VAMI_CLI using "/opt/vmware/share/vami/vami_config_net" will work but the vCenter will still not be able to fetch updates.
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Environment

VMware vCenter Server 6.7.x
VMware vCenter Server 7.0.x

Cause

The vCenter Server VAMI interface relies on ICMP replies from proxy server to configure the Proxy Settings and communicate with the proxy server properly, If ICMP is blocked on the Proxy Server from the customer side, the vCenter will not be able to connect to the proxy server and grab the URL updates.



Resolution

currently there is no resolution for this problem.

Make sure the customer has enabled ICMP Pings for the proxy machine to be reachable to the vCenter.

Workaround:
There is no workaround available.

Additional Information

Impact/Risks:
vCenter patches fetched through the VAMI interface will not work if it's relying on a proxy server to connect to the internet.