The Cloud Director Availability plug-in is not visible in the Cloud Director main menu in Cloud Director Availability 4.x
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The Cloud Director Availability plug-in is not visible in the Cloud Director main menu in Cloud Director Availability 4.x

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Article ID: 315155

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • The Cloud Director Availability plug-in is not available in the Cloud Director main menu (☰).
  • In the Customize Portal view of the Cloud Director Provider Portal, you see the Cloud Director Availability plugin is registered.
  • In /opt/vmware/vcloud-director/logs/debug-container.log on the Cloud Director cell, you see an similar message:
2019-12-03 15:20:43,544 | DEBUG  | auto-pool-Monitor Service-59-thread-3 | ReceivingSocketImpl      | Resource plugin.zip not fully transferred yet (0/1,377,667) for transfer session 5b310eec-29d7-418a-b34f-10962604bfdd |
 
Note: The preceding log excerpts are only examples. Date, time, and environmental variables may vary depending on your environment.


Environment

VMware vCloud Availability 3.0.x
VMware Cloud Director Availability 4.x
VMware vCloud Availability 3.5.x

Cause

This issue can occur when Cloud Director's load balancer is not configured for SSL passthrough. When using SSL termination on the Cloud Director load balancer, the transfer link used to upload the plug-in can not be read by Cloud Director Availability causing the upload to time out.

Resolution

This is a known issue affecting Cloud Director Availability 4.x.
Currently, there is no resolution.

Workaround:
To work around this issue, reconfigure Cloud Director to use SSL passthrough to allow the Cloud Director Availability plug-in registration to complete successfully: 
  1. Navigate to the Customize Portal view in the Cloud Director Provider Portal.
  2. Select the Cloud Director Availability plug-in and click Delete.
  3. In the pop-up window, click Save.
  4. Temporally enable SSL passthrough for the Load Balancer in front of Cloud Director.
  5. Navigate to the Configuration view in the Cloud Director Availability Provider Portal.
  6. Click Edit on Cloud Director address.
  7. In the pop-up window, re-enter the Cloud Director credentials and click Apply.
  8. Navigate to and refresh the Cloud Director Portal.
  9. Confirm that you can see the Cloud Director Availability option in the main menu (☰).