Accessing the Provider Portal fails when using the Service Endpoint address in Cloud Director Availability
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Accessing the Provider Portal fails when using the Service Endpoint address in Cloud Director Availability

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Article ID: 315152

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Symptoms:
  • Accessing the Cloud Director Availability public facing Provider Portal interface does not load when using the fully qualified domain name (FQDN) specified in the Service Endpoint address.
  • The public facing Provider Portal interface loads correctly when using the IP address or an alternate FQDN that points to the same IP address.
  • Attempts to connect to port 8443 on the Cloud Replication Management Appliance from the Cloud Tunnel Appliance fail when using its FQDN.
  • Attempts to connect to port 8046 on the Cloud Replication Management Appliance from the Cloud Tunnel Appliance using the IP address succeed.


Environment

VMware Cloud Director Availability 4.x
VMware vCloud Availability 3.0.x
VMware vCloud Availability 3.5.x

Cause

This issue occurs because inbound connections to the Cloud Tunnel Appliance via the Service Endpoint address are routed to the Cloud Replication Management Appliance on port 8443 using its hostname while connections via any alternative URI (e.g., IP address) are routed to the Cloud Replication Management Appliance IP address using the default 8046 port. If the tunnel is unable to resolve the Cloud Replication Management Appliance hostname or cannot connect on port 8443, the Provider Portal cannot be accessed via the Service Endpoint address.

Resolution

To resolve this issue, perform the following steps to correct this behavior:
  1. Confirm that port 8443 is open between the Cloud Tunnel Appliance and the Cloud Replication Management Appliance.
  2. Test that the Cloud Replication Management Appliance hostname is resolvable from the Cloud Tunnel Appliance.
    1. Log in to the management interface of the Cloud Replication Management Appliance.
      1. In a Web browser, go to https://Appliance-IP-Address/ui/admin.
      2. Select Appliance login or SSO login and enter the root or the single sign-on user credentials.
      3. Click Login.
    2. In the left pane, navigate to Configuration > Settings.
    3. In the Settings view scroll down to Appliance Settings > Network.
    4. Click the copy button beside the hostname in the Network section.
    5. SSH to the Cloud Tunnel Appliance and log in as the root user.
    6. Attempt to ping the Cloud Replication Management Appliance hostname.
  3. If the hostname does not resolve correctly, adjust the DNS configuration or correct the Cloud Replication Management Appliance hostname to include a resolvable address.


Additional Information

For more information, see the Network Requirements section of the Cloud Director Availability documentation.